Ник:
Пароль:

Контакты

Cтатус Skype: starterkit.ru
тел.: (+7 3412) 478-448
тел.: +7 922 680-21-73
тел.: +7 922 680-21-74
E-mail: info@starterkit.ru
Партнеры:
otladka.com.ua - г.Киев

Способы оплаты

User Info


Добро пожаловать,
Guest

Регистрация или входРегистрация или вход
Потеряли пароль?Потеряли пароль?

Ник:
Пароль:

ПользователейПользователей:7
Поисковых ботовПоисковых ботов:3
ГостейГостей:1

ОбновитьПодробнееВсегоВсего:11
Форум » starterkit.ru » Embedded Linux
Доработка встраиваемого линукс с gui оболочкой.
turboStarter
Добавлено 14.02.2020 21:22
5
Сообщение: 1
turboStarter
5

Пункты: 622
Регистрация: 21.11.2019
Здравствуйте!
Я использую сборку с ui , любезно предоставленную Вашим сайтом, с заменой ядра, которое собирается билдрутом. Повторюсь, огромнейшее Вам спасибо за помощь в настройке тачскрина!
Вот этот пост http://www.starterkit.ru/html/index.php?name=forum&op=view&id=30284

Хотелось бы еще уточнить решение по некоторым трудностям
1) Монтирование диска hdd после загрузки ос.
2) Добавка репоситориев с mono, с экранной клавиатурой, и кирилическая раскладка.

Начну с первого

У меня есть жесткий диск, сама ос его видит как volume 64GB. Он определен как /dev/sda /dev/sda1
Когда я делаю mout /dev/sda1 /mnt/hdd , все проходит и диск монтируется. Но мне необходимо монтировать его автоматически во время загрузки системы.

Я нашел uuid этого диска и прописал в fstab строки
UUID=********** /mnt/hdd ext4 defaults,nofail 0 0

И если сделать после этого mount -a, то все смонтируется.
Но стоит перезагрузиться, как все тут же теряется, и нужно перезапускать mount вручную для fstab.

Следующая попытка которую я предпринял была в создании systemd.mount файла. Файл находился в директории /lib/systemd/system

mnt-hdd.mount

[Unit]
Description=HDD device

[Mount]
What=/dev/disk/by-uuid/*******
Where=/mnt/hdd
Type=ext4
Options=defaults,nofail

[Install]
WantedBy=multi-user.target

Потом сделал systemctl daemon-reload
И зарегистрировал mount файл.

Когда сделал systemctl start mnt-hdd.mount
и проверил его systemctl status, все отработало корректно.
После перезагрузки, он снова не подмонтировался автоматически, но проверив его статус я получил.
dependency failed for hdd device
mnt-hdd.mount: job mnt-hdd.mount/start failed with result 'dependency'

Похоже, что он пытается его примонтировать , при первичном буте самого ядра, но может я ошибаюсь. Искал в интернете лечение данной проблеммы, найти не удалось. Вот теперь пишу Вам, надеюсь ответите.
Спуститься к концу Подняться к началу
Персональная информация
sasamy
Добавлено 19.02.2020 08:19 Редактировалось 19.02.2020 08:20 Сообщение: 2
sasamy
4.77

Пункты: 57420
Регистрация: 14.08.2009
Цитата
Искал в интернете лечение данной проблеммы, найти не удалось.


на вид вроде всё правильно прописано - должно работать с fstab и с systemd

https://losst.ru/avtomaticheskoe-montirovanie-fstab-i-systemd

возможно драйвер диска модулем собран и во время монтирования еще не загружен udev-ом
Спуститься к концу Подняться к началу
Персональная информация
turboStarter
Добавлено 20.02.2020 18:03 Редактировалось 24.02.2020 20:15 Сообщение: 3
turboStarter
5

Пункты: 622
Регистрация: 21.11.2019
Цитата
Цитата
Искал в интернете лечение данной проблеммы, найти не удалось.


на вид вроде всё правильно прописано - должно работать с fstab и с systemd

https://losst.ru/avtomaticheskoe-montirovanie-fstab-i-systemd

возможно драйвер диска модулем собран и во время монтирования еще не загружен udev-ом

Спасибо за подсказку, но fstab поднять во время загрузки не удалось, я сделал обход
https://unix.stackexchange.com/questions/388837/systemd-run-script-after-gui-is-ready

Теперь другая трудность, в моей плате 2 ethernet разьема, 1й через smsc95xx, воторой простой ethernet, драйвер в мою конфигурация ядра добвавлен, при этом подключение при загрузке работает корректно только через com драйвер, обычный ethernet показывает какую-то лажу:
IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 10.418231] fec 2188000.ethernet eth0: Freescale FEC PHY driver [SMSC LAN8710/LAN8720] (mii_bus:phy_addr=2188000.ethernet:00, irq=-1)


когда я делаю
/etc/init.d/networking stop

За тем включаю ethernet кабель в первый разьем, где com драйвер ,соединение есть, затем подключаю кабель ко второму разему, драйвер подключается и dmesg показывает что все ок, но я не могу сконфигурировать оба ethernet разьема через /etc/network/interfaces , даже когда отключаю networkmanager через systemctl. Подскажите куда копать.
Спуститься к концу Подняться к началу
Персональная информация
Форум » starterkit.ru » Embedded Linux