Ник:
Пароль:

Контакты

Cтатус Skype: starterkit.ru
тел.: (+7 3412) 478-448
тел.: +7 922 680-21-73
тел.: +7 922 680-21-74
E-mail: info@starterkit.ru
Партнеры:
otladka.com.ua - г.Киев

Способы оплаты

User Info


Добро пожаловать,
Guest

Регистрация или входРегистрация или вход
Потеряли пароль?Потеряли пароль?

Ник:
Пароль:

ПользователейПользователей:1
Поисковых ботовПоисковых ботов:2
ГостейГостей:1

ОбновитьПодробнееВсегоВсего:4
Форум » starterkit.ru » Embedded Linux
VLC player - imx6sk + Boundary Debian 9
SmartRogue
Добавлено 18.06.2018 16:58
0
Сообщение: 1
SmartRogue
0

Пункты: 1449
Регистрация: 27.11.2017
Здравствуйте.

Что имею?
Плату imx6sk, накачен Debian 9 Boundary & sasamy (тык).

Что хочу?
Смотреть видосики через VLC.

Что делал?
На свежей системе:
Код
sudo apt update && sudo apt install -y vlc


Что получил?
При попытке вопроизвести видео:
Код
egl_x11 gl error: cannot select OpenGL API


Что ещё делал?
Убедился, что в lsmod есть galcore.
В VLC пробовал различные варианты output, а также пробовал отключать аппаратное ускорение декодирования. Видео так и не добился, только аудио.

Спасите-помогите убогому плиззз.
Спуститься к концу Подняться к началу
Персональная информация
sasamy
Добавлено 18.06.2018 18:05 Сообщение: 2
sasamy
4.77

Пункты: 64519
Регистрация: 14.08.2009
Цитата

Что хочу?
Смотреть видосики через VLC.


VLC не поддерживает аппаратное декодирование для imx6 так что ничего хорошего с ним не выйдет даже если подберете работающий плагин отображения видео
Спуститься к концу Подняться к началу
Персональная информация
SmartRogue
Добавлено 19.06.2018 11:37 Сообщение: 3
SmartRogue
0

Пункты: 1449
Регистрация: 27.11.2017
Цитата

VLC не поддерживает аппаратное декодирование для imx6 так что ничего хорошего с ним не выйдет даже если подберете работающий плагин отображения видео


О как... Спасибо!

То есть, городить нечто подобное тому, что в демках у Boundary лежит? На базе gstreamer...
Спуститься к концу Подняться к началу
Персональная информация
Форум » starterkit.ru » Embedded Linux