Ник:
Пароль:

Контакты

Cтатус Skype: starterkit.ru
тел.: (+7 3412) 478-448
тел.: +7 922 680-21-73
тел.: +7 922 680-21-74
E-mail: info@starterkit.ru
Партнеры:
otladka.com.ua - г.Киев

Способы оплаты

User Info


Добро пожаловать,
Guest

Регистрация или входРегистрация или вход
Потеряли пароль?Потеряли пароль?

Ник:
Пароль:

ПользователейПользователей:0
Поисковых ботовПоисковых ботов:3
ГостейГостей:1

ОбновитьПодробнееВсегоВсего:4
Форум » starterkit.ru » Embedded Linux
imx6 и gstreamer-1.0
kosyak©
Добавлено 16.11.2016 09:31
0
Сообщение: 1
kosyak©
0

Пункты: 941
Регистрация: 20.09.2016
Собрал buildroot-2015.08-sk
запускаю
gst-play-1.0 0.mp4

в com порт валится

mxc_vpu 2040000.vpu_fsl: VPU blocking: timeout.
mxc_vpu 2040000.vpu_fsl: VPU blocking: timeout.
mxc_vpu 2040000.vpu_fsl: VPU blocking: timeout.
mxc_vpu 2040000.vpu_fsl: VPU blocking: timeout.
[galcore]: GPU[0] hang, automatic recovery.
[galcore]: recovery done

Повторный вызов gst-play-1.0 подвешивает систему.

У кого нибудь получилось использовать gstreamer-1.0 в buildroot-2016.02-sk и buildroot-2015.08-sk?
Спуститься к концу Подняться к началу
Персональная информация
sasamy
Добавлено 16.11.2016 20:38 Редактировалось 16.11.2016 20:40 Сообщение: 2
sasamy
4.77

Пункты: 57420
Регистрация: 14.08.2009
У вас плата не местная ? Очень похоже что версия драйвера в ядре не совпадает с версией библиотек OpenGL в юзерспейс. На местных платах все должно работать, сэмплы для тестов можно тут взять, а то неизвестно что вы тестируете

http://www.sample-videos.com/
Спуститься к концу Подняться к началу
Персональная информация
kosyak©
Добавлено 17.11.2016 08:31 Сообщение: 3
kosyak©
0

Пункты: 941
Регистрация: 20.09.2016
Плата imx6q-sk.
Хост система Lubuntu 16.04 x32.

Пробовал buildroot-2015.08-sk и buildroot-2016.02-sk. Сборка проходит без ошибок.

Попробую сэмплы с этого сайта, но тестировал я на разных источника/файлах - везде такая ерунда.
Спуститься к концу Подняться к началу
Персональная информация
sasamy
Добавлено 17.11.2016 09:38 Сообщение: 4
sasamy
4.77

Пункты: 57420
Регистрация: 14.08.2009
Цитата

Плата imx6q-sk.


Покажите лог загрузки u-boot и вывод команды clock в консоли убута

u-boot > clock
Спуститься к концу Подняться к началу
Персональная информация
kosyak©
Добавлено 17.11.2016 11:19 Редактировалось 17.11.2016 11:53 Сообщение: 5
kosyak©
0

Пункты: 941
Регистрация: 20.09.2016
Логи.
https://dl.dropboxusercontent.com/u/15370742/boot.log
https://dl.dropboxusercontent.com/u/15370742/uboot-clock.log

Пробовал файл с сайта http://www.sample-videos.com/

Код

#gst-play-1.0 sampleVideo_1280x720_20mb.mp4
Press 'k' to see a list of keyboard shortcuts.
Now playing /media/usb0/sampleVideo_1280x720_20mb.mp4
[INFO]libitstreamMode 1, chromaInterleave 0, mapType 0, tiled2LinearEnable 0
Redistribute latency...
[ERR]02.fatal: VPU is busy in vpu_DecGetOutputInfo
ERROR GStreamer encountered a general stream error. for file:///media/usb0/sampleVideo_1280x720_20mb.mp4
ERROR debug information: qtdemux.c(5423): gst_qtdemux_loop (): /GstPlayBin:playbin/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0/GstQTDemux:qtdemux0:
streaming stopped, reason error


Лог терминала
Код

Welcome to Buildroot
buildroot login: ci_hdrc ci_hdrc.0: Device No Response
fec 2188000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
random: nonblocking pool is initialized
mxc_vpu 2040000.vpu_fsl: VPU blocking: timeout.
mxc_vpu 2040000.vpu_fsl: VPU blocking: timeout.
mxc_vpu 2040000.vpu_fsl: VPU blocking: timeout.
mxc_vpu 2040000.vpu_fsl: VPU blocking: timeout.
[galcore]: GPU[0] hang, automatic recovery.
[galcore]: recovery done
Спуститься к концу Подняться к началу
Персональная информация
kosyak©
Добавлено 17.11.2016 12:02 Сообщение: 6
kosyak©
0

Пункты: 941
Регистрация: 20.09.2016
Решил попробовать без аппаратных кодеков.
Собрал ffmpeg (buildroot-2015.08-sk).
Запускаю
#ffplay sampleVideo_1280x720_20mb.mp4

Файл проигрывается, но если грохнуть процесс ffplay (например ctrl+c), второй раз запустить его уже нельзя - он тупо виснет при старте, ничего не отображая на экран.
Спуститься к концу Подняться к началу
Персональная информация
sasamy
Добавлено 17.11.2016 12:40 Редактировалось 17.11.2016 12:55 Сообщение: 7
sasamy
4.77

Пункты: 57420
Регистрация: 14.08.2009
Какая у вас ревизия платы ? должно быть на плате написано типа V1.B. В логах все нормально, но непонятно почему не работает - у себя я много раз проверял и никаких проблем нет, единственное объяснение этому - распаян другой тип памяти или другая ревизия и требуется новая калибровка для DDR. Попробуйте сменить настройки памяти в директории

buildroot-2015.08-sk/output/build/uboot-custom/board/starterkit/sk_imx6

$ cp sk_quad_old.cfg sk_quad.cfg

и пересобрать u-boot

в корне исходников buildroot

$ make uboot-rebuild

при такой пересборке исходники убута не распаковываются заново из архива а соберется то что есть с изменениями. Дальше записать по инструкции через mk-sd.sh. Если то что зашито штатно в нанде работает - с этими настройками должно заработать.
Спуститься к концу Подняться к началу
Персональная информация
kosyak©
Добавлено 17.11.2016 13:35 Сообщение: 8
kosyak©
0

Пункты: 941
Регистрация: 20.09.2016
Ревизия платы 1.Е

После смены настроек дальше uboot не грузится вообще.

Код

U-Boot 2014.04 (Nov 17 2016 - 13:02:50)

CPU: Freescale i.MX6Q rev1.2 at 792 MHz
CPU: Temperature 21 C, calibration data: 0x5724de69
Reset cause: POR
Board: SK-iMX6Q
DRAM: 1 GiB
NAND: 1024 MiB
MMC: FSL_SDHC: 0, FSL_SDHC: 1
*** Warning - bad CRC, using default environment

Net: Phy not found
FEC
Normal Boot
Hit any key to stop autoboot: 0
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size: 131072 bytes (128 KiB)
UBI: logical eraseblock size: 126976 bytes
UBI: smallest flash I/O unit: 2048
UBI: VID header offset: 2048 (aligned 2048)
UBI: data offset: 4096
UBI error: ubi_read_volume_table: the layout volume was not found
UBI error: ubi_init: cannot attach mtd1
UBI error: ubi_init: UBI error: cannot initialize UBI, error -22
UBI init error 22
UBIFS error (pid 0): ubifs_get_sb: cannot open "ubi0:rootfs", error -19
UBIFS error (pid 0): ubifs_mount: Error reading superblock on volume 'ubi0:rootfs' errno=-19!

ubifsmount - mount UBIFS volume

Usage:
ubifsmount <volume-name>
- mount 'volume-name' volume
UBIFS not mounted, use ubifs mount to mount volume first!
ubifsload - load file from an UBIFS filesystem

Usage:
ubifsload <addr> <filename> [bytes]
- load file 'filename' to address 'addr'
UBIFS not mounted, use ubifs mount to mount volume first!
ubifsload - load file from an UBIFS filesystem

Usage:
ubifsload <addr> <filename> [bytes]
- load file 'filename' to address 'addr'
Bad Linux ARM zImage magic!
u-boot >
Спуститься к концу Подняться к началу
Персональная информация
sasamy
Добавлено 17.11.2016 13:43 Редактировалось 17.11.2016 13:46 Сообщение: 9
sasamy
4.77

Пункты: 57420
Регистрация: 14.08.2009
Цитата

После смены настроек дальше uboot не грузится вообще.

UBI error: ubi_read_volume_table: the layout volume was not found


Попробуйте для начала с SD загрузиться и воспроизвести видео - отложите пока эксперименты с nand.

Цитата

Ревизия платы 1.Е


явно новая ревизия - у меня 1.B
Спуститься к концу Подняться к началу
Персональная информация
kosyak©
Добавлено 17.11.2016 13:54 Редактировалось 17.11.2016 14:01 Сообщение: 10
kosyak©
0

Пункты: 941
Регистрация: 20.09.2016
Собрал buildroot-2014.08-sk.

gst-launch -v filesrc location=/media/usb0/sampleVideo_1280x720_20mb.mp4 typefind=true ! decodebin2 ! mfw_v4lsink

работает нормально, только некоторые файлы не до конца проигрываются
Цитата

Попробуйте для начала с SD загрузиться и воспроизвести видео - отложите пока эксперименты с nand.

хм.. для меня пока это все сложно. Сменил я настройки uboot
Цитата

#cp sk_quad_old.cfg sk_quad.cfg
make uboot-rebuild


записал все на sd - не грузится (.
Спуститься к концу Подняться к началу
Персональная информация
Форум » starterkit.ru » Embedded Linux