Ник:
Пароль:

Контакты

E-mail: info@starterkit.ru
тел.: +7 922 680-21-73
тел.: +7 922 680-21-74
Телеграм: t.me/starterkit_ru
Партнеры:
otladka.com.ua - г.Киев

Способы оплаты

User Info


Добро пожаловать,
Guest

Регистрация или входРегистрация или вход
Потеряли пароль?Потеряли пароль?

Ник:
Пароль:

ПользователейПользователей:1
Поисковых ботовПоисковых ботов:3
ГостейГостей:1

ОбновитьПодробнееВсегоВсего:5
Форум » starterkit.ru » Embedded Linux
нет изображения с web-камеры
asimo
Добавлено 30.01.2012 14:21
0
Сообщение: 1
asimo
0

Пункты: 1685
Регистрация: 27.12.2011
парни, подскажите куда копать. есть вебка genius islim-1320. под убунтой завелась, в дебиане 2.6.3 ни в какую.
по действиям:
#lsusb
"bus 001 device 007: id 0458:7060 kye system corp.(mouse system)"

настройка ядра согласно
http://sasamy.narod.ru/uvc/0.png
http://sasamy.narod.ru/uvc/1.png
http://sasamy.narod.ru/uvc/2.png
http://sasamy.narod.ru/uvc/3.png
http://sasamy.narod.ru/uvc/4.png
http://sasamy.narod.ru/uvc/5.png
http://sasamy.narod.ru/uvc/6.png
http://sasamy.narod.ru/uvc/7.png
http://sasamy.narod.ru/uvc/8.png

в итоге чиз висит, каморама выдает ошибку "could not connect to video device (/dev/video0)", tvtime тоже ругается на видео0
файл /dev/video0 есть.

группу video создал, пользователя туда прописал:
#sudo addgroup video
the group video already exists
#sudo useradd -G video user
unable to resolve host debian
useradd: user user exists

хотя что меня напрягло, почему-то не создалась папка /etc/group/video/ так и должно быть..?

что еще проверить или сделать чтоб она наконец-то заработала..?
Спуститься к концу Подняться к началу
Персональная информация
sasamy
Добавлено 30.01.2012 14:59 Сообщение: 2
sasamy
4.70

Пункты: 77362
Регистрация: 14.08.2009
Цитата

дебиане 2.6.3


Это из какого века ? :) UVC камеры прекрасно работают - проверял на всех доступных мне платах, а это все процессоры на базе которых и все остальные недоступные мне платы.
Спуститься к концу Подняться к началу
Персональная информация
asimo
Добавлено 30.01.2012 18:21 Сообщение: 3
asimo
0

Пункты: 1685
Регистрация: 27.12.2011
:D 2.6.36 конечно же.
Спуститься к концу Подняться к началу
Персональная информация
sasamy
Добавлено 30.01.2012 18:49 Редактировалось 30.01.2012 19:14 Сообщение: 4
sasamy
4.70

Пункты: 77362
Регистрация: 14.08.2009
Если вы ставите бинарный дистрибутив на свое кастомное ядро - вы всегда рискуете попасть на несовместимость интерфейса в ядре для подобных устройств (разумеется если версии ядер дистрибутива и вашего совпадают - этого не произойдет), но интерфейс не так часто меняется. Не знаю - что в данном случае у вас не так, я пользуюсь mplayer, если будете собирать в buildroot, там нужно поправить конфиг его сборки, найдите в файле
buildroot-2010.08/package/multimedia/mplayer/mplayer.mk
вот это место
Код

...
$(MPLAYER_FREETYPE) \
--enable-cross-compile \
--disable-ivtv \
--disable-tv \
--disable-live \
...

нужно удалить вот эту строчку
--disable-tv \
Спуститься к концу Подняться к началу
Персональная информация
asimo
Добавлено 07.02.2012 07:27 Сообщение: 5
asimo
0

Пункты: 1685
Регистрация: 27.12.2011
не помогло, тот же зеленый экран
Спуститься к концу Подняться к началу
Персональная информация
lunixoid
Добавлено 07.02.2012 12:39 Сообщение: 6
lunixoid
0

Пункты: 1050
Регистрация: 18.01.2012
Пол: Мужчина
Из: Ростов-на-Дону
У меня похожая проблема, собрал ядро с настройками как на скринах, подключаю вебку, но изображения с нее не получаю. Пробовал в OpenCV подключить камеру, пишет не может, тот же код на Ubuntu спокойно находит вебку и получает изображение.
Спуститься к концу Подняться к началу
Персональная информация
lunixoid
Добавлено 29.02.2012 17:21 Сообщение: 7
lunixoid
0

Пункты: 1050
Регистрация: 18.01.2012
Пол: Мужчина
Из: Ростов-на-Дону
Тогда вопрос с другой стороны - каким способом можно получить изображение с вебкамеры по usb ? )
Спуститься к концу Подняться к началу
Персональная информация
Jury093
Добавлено 02.03.2012 09:15 Сообщение: 8
Jury093
4.5

Пункты: 54233
Регистрация: 25.05.2009
Пол: Мужчина
Из: Санкт-Петербург
Цитата
Тогда вопрос с другой стороны - каким способом можно получить изображение с вебкамеры по usb ? )

каким-каким - обычным

- сначала в ядре в разделе Multimedia поднимаем поддержку Video for Linux (как то так звучит), включаем поддержку свой камеры или UVC (если вебка этого класса)
пересобираем, грузим, проверяем в логе опознание камеры и появление устройства в /dev
потом берем подходящий грабер и "грабим".. ключи для грабления зависят от камеры и софтины..

На любой вопрос есть любой ответ.
Спуститься к концу Подняться к началу
Персональная информация
lunixoid
Добавлено 05.03.2012 16:27 Сообщение: 9
lunixoid
0

Пункты: 1050
Регистрация: 18.01.2012
Пол: Мужчина
Из: Ростов-на-Дону
после сборки ядра с поддержкой драйвера uvc в /dev независимо от того, подключена ли вебка или нет, video0 и video1 всегда висит. Граббер написан собственными силами на opencv, на убунте он работает, на плате даже не подключается к камере.
Спуститься к концу Подняться к началу
Персональная информация
Jury093
Добавлено 07.03.2012 09:34 Сообщение: 10
Jury093
4.5

Пункты: 54233
Регистрация: 25.05.2009
Пол: Мужчина
Из: Санкт-Петербург
Цитата
после сборки ядра с поддержкой драйвера uvc в /dev независимо от того, подключена ли вебка или нет, video0 и video1 всегда висит.

вот это настораживает.. когда я игрался с камерами, то video0 появлялся в момент подключения и опознания камеры драйверами. что идеологически правильно..

На любой вопрос есть любой ответ.
Спуститься к концу Подняться к началу
Персональная информация
Форум » starterkit.ru » Embedded Linux